Some stats are not loading.
Resolved
May 13, 2026 at 12:59pm UTC
The issue is now fixed.
Affected services
Updated
May 13, 2026 at 10:54am UTC
We're still working on a fix for the coach dashboard charts not loading.
Affected services
Updated
May 13, 2026 at 10:48am UTC
We've resolved the issue with player stats not appearing on their page. We are still working on fixing the coach dashboard.
Affected services
Updated
May 13, 2026 at 10:34am UTC
We've identified the root cause of the issue and will resolve it within the next 15 minutes.
Affected services
Created
May 13, 2026 at 10:17am UTC
We've been made aware that some pages have error messages when trying to load stats. We are working on a fix.
Affected services