Video processing delayed
Resolved
Apr 18, 2026 at 2:49pm UTC
Our video hosting provider has resolved the issue. We are now expecting games to process as normal. We will be conducting a full post-mortem with more information.
Affected services
Updated
Apr 18, 2026 at 1:54pm UTC
Our video hosting provider has resolved the issue on their end. We're now back filling and processing footage, and expecting return to normalcy within an hour.
Affected services
Updated
Apr 18, 2026 at 12:26pm UTC
We're still waiting for our video hosting provider to fix the issue.
Affected services
Updated
Apr 18, 2026 at 12:02pm UTC
Our video posting provider estimates it will take another "couple of hours" before the video processing continues.
Affected services
Updated
Apr 18, 2026 at 11:07am UTC
We are still communicating with our video hosting provider to get further updates.
Affected services
Updated
Apr 18, 2026 at 10:51am UTC
We're continuing to communicate with our video hosting provider to resolve this issue.
Affected services
Created
Apr 18, 2026 at 9:58am UTC
Due to a disruption in our video hosting provider, footage processing is delayed.
Affected services