Back to overview
Degraded
Presentation share links unavailable
Mar 31, 2026 at 9:33am UTC
Affected services
framesports.ai
Resolved
Mar 31, 2026 at 9:43am UTC
We've resolved the issue.
Affected services
Created
Mar 31, 2026 at 9:33am UTC
We've received reports that users are experiencing an error when viewing a presentation through a share link. We're investigating this issue and will report on updates.
Affected services