Back to overview
Degraded

Bulk-adding new clips to presentations is degraded

Mar 24, 2026 at 7:38am UTC
Affected services
framesports.ai

Resolved
Mar 24, 2026 at 7:55am UTC

The issue is now resolved.

Created
Mar 24, 2026 at 7:38am UTC

We are seeing reports that bulk-adding clips into a presentation is degraded. We're working on a fix.